neoDSI   développeur web freelance symfony & wordpress
+33 6 62 75 87 89 Contact

xampp 1.8.2 et symfony2 : problème icu et apc

article apache et symfony2

Pour symfony2.3 il est nécessaire d’avoir l’extension intl d’activée et ainsi que apc.

L’extension intl est facile à activer dans le fichier php.ini, par contre apache il peut arriver seleon l’installation de apache que celui ci indique que le fichier icuuc49.dll est introuvable.

Vous pouvez résoudre le problème en copiant les 8 fichiers icuxxx.dll du repertoire php dans le répertoire bin de apache.

Pour l’extension apc on trouve souvent (sur le site http://downloads.php.net/pierre/) la version 3.1.10 ( php_apc-3.1.10-5.4-vc9-x86.zip\ts dans mon cas) mais il faut une version supérieure à 3.1.13
Pour windows on peut les trouver sur http://dev.freshsite.pl/php-accelerators/apc.html

Penser à bien mettre dans le fichier php.ini :
[APC]
apc.enabled=1

Et pour les autres options voir http://www.siteduzero.com/informatique/tutoriels/accelerer-la-generation-de-vos-pages-php-avec-l-extension-apc/configuration-de-l-extension